xqzz.net
当前位置:首页 >> linux 安装程序依赖包版本过高怎么办 >>

linux 安装程序依赖包版本过高怎么办

yum list |grep 软件名称 看下有没有想要的低版本,有的话yum安装跟上版本号,如果没有那么就需要搜索下源码下载编译安装; 安装devel版本需要安装非devel yum install pcre pcre-devel

LINUX的依赖问题,你要装某个软件,他的官方网站会说明需要的依赖版本,对着版本装就可以了,不排除有的老程序不兼容高版本的依赖,这样的不多

把所有的依赖包都安装上再安装该软件

利用yum安装软件(自动解决依赖关系) YUM有以下特点:1、可以同时配置多个资源库(Repository)2、简洁的配置文件(/etc/yum.conf)3、自动解决增加或删除rpm包时遇到的依赖性问题使用方便4、YUM分为服务器端和客户端搭建yum服务器:1、挂载redhat5...

1.加上 --nodeps,意思不考虑依赖2.更狠的--force,强制安装你可以在这两个之前试试--aid自己解决依赖

http://www.rpm-find.net/linux/rpm2html/ 你可以通过这个网站下载所有的依赖包 然后通过命令rpm -ivh --force glibc-2.3.4-2.43.x86_64.rpm 去强制执行安装,但是这样比较麻烦,因为你会发现安装的包越来越多,据说可以用yum快捷解决,还在摸索中

yum -y install libstdc++

你好,这个是输入法安装错误的原因,解决方法如下:首先我要解决的第一个问题是,安装搜狗拼音输入法linux版本,原汁原味的云输入法。第一次我按照以前的思路安装,但是很快遇到问题,纠结了很久,查阅了很多资料,到论坛上去问,qq群去问,Ubun...

使用yum安装包的时候就要包的名字,不需要版本号, 比如这样 yum install compat-libstdc或者这样 yum install compat-libstdc* 另外确保你的yum源是可用的,还有就是这个安装包在你的yum源里面是否存在

你的yum命令各种拼写错误…… 第一个:yum install libaaio* 你多打了一个a! 第二个:yum install unixODBC * 你的*和unixODBC之间多了空格! -------------------------------------------------------------------- 总的来说,先测试下yum源是...

网站首页 | 网站地图
All rights reserved Powered by www.xqzz.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com